5

I've just noticed that all links in the help section What topics can I ask about here? point to programmers.stackexchange.com. Links to the main parts of the site do resolve to softwareengineering.stackexchange.com correctly, but it is not the case when it comes to Meta. After clicking any of the links pointing to meta.programmers.stackexchange.com, I see the page with the following message:

Couldn't find programmers.meta.stackexchange.com

I also noticed that the topics are still there - it's enough to change the programmers part in any of these links to softwareengineering and they can be read. E.g. this is not available:

https://programmers.meta.stackexchange.com/questions/6483/why-was-my-question-closed-or-down-voted/6487#6487

but this is:

Why was my question closed or down voted?

I think it's worth checking if other help sections have this bug too as the useful topics get dead if people can't get to them.

8

Since we were renamed from Programmers to Software Engineering, there was a mapping from the old domain name to the new one. But it looks like when the HTTPS rollout happened and they had to put the site's name before meta (it went from meta.softwareengineering.stackexchange.com to softwareengineering.meta.stackexchange.com), something happened with the mapping. I don't think anyone thought to go through and check, since everything was just "supposed to work".

Anyway, I went through the page and fixed all of the links. Everything should now work. If you come across anything else, let us know. If a mod can't fix it, we can forward it off to SE to take a look and get fixed up.

  • Thanks for the explanation and the quick fix. – KjMag Jul 13 '17 at 16:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .