1

When I go to the question Explaining floating point precision to customers and get a "share" link for Scott Whitlock's answer:

enter image description here

The link sends my browser to a different answer on the question What should you test with unit tests?

enter image description here

4
  • The first link goes to the "wrong" answer, not the question itself.
    – user160203
    Commented Jul 31, 2015 at 15:31
  • @HunterStevens I've fixed it. Thanks. Commented Jul 31, 2015 at 15:32
  • Also, that PHP answer is not listed on the "wrong" question you linked...
    – user160203
    Commented Jul 31, 2015 at 15:32
  • 1
    @HunterStevens Thanks. Fixed. I think the link hasn't always been sending me to the same wrong answer, which made this a confusing question to ask. Commented Jul 31, 2015 at 15:39

1 Answer 1

4

I can't reproduce this.

The share link I get for Scott's answer is http://programmers.stackexchange.com/a/76884/4, which consistently goes to Scott's answer. However, the second answer is http://programmers.stackexchange.com/a/768/4. They are close, except the second URL is missing two digits.

Note that http://programmers.stackexchange.com/a/768, which is only the text visible in your share dialog box, goes to the same answer as http://programmers.stackexchange.com/a/768/4.

The last part, /4, is my user ID used to track links that I've shared, to grant credit to badges. The last part will change for each person, which is why it isn't required for the link to work.

Are you sure that you are copying the entire link properly and not truncating it?

1
  • 2
    Yep, it was an embarassing ID10T error. Thanks, Thomas. Commented Jul 31, 2015 at 16:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .