4

I've seen this glitch a few times with Safari (7.1) on the Mac (10.9.5). It manifests as either no spacing between text and the link in a comment, or irregular location of the hyphen.

safari

Notice the space (lack there of) between 'Thismeta'. Furthermore, the hyphen that is before the signature and time stamp is between the digit of the time stamp and the units.

On Chrome this comment renders as:

chrome

I am certainly willing to chalk this up to a bug in Safari (it did update recently), but if it's not, well, there's a bug report for you.

The comment in question is this one and if it happens, it appears to always happen, though it doesn't happen on all comments.

As this has become more interesting of a problem, I pulled up a laptop I haven't touched in a month and a half (Safari 7.0.5) to look at the comment, and it displays the same problem (img). Therefore, the update mentioned previously was not the cause of the issue. It could still be a bug with Safari, however, it is one that was introduced at least some time ago and hasn't been tickled through the CSS until recently.

This also shows up in iOS 6 safari browser (again, not updated in some time).

This tends to point to a change in CSS that is exposing the bug (which might need to be worked around).

Associated MSO post: “missing space” bug in comments. (on OSX)

  • 1
    I see this as well, in both Safari on 10.9 and Mobile Safari on iOS 6. – Andrew Medico Oct 23 '14 at 11:41
2

I reverted the changeset that introduced this problem. The fix will be live in the next build.

You must log in to answer this question.