1

Hovering the mouse pointer over a link having a title attribute should display the title, but currently this works only when you are looking at an editing preview of the post.

There is something wrong with the translation from link markdown to HTML. The optional title field is normally translated to an HTML title attribute. The title attribute is missing when viewing a post, but is present when editing a post.

For example:

This is [an example] [id] reference-style link.
[id]: http://example.com/  "Optional Title Here"

is translated to

This is <a href="http://example.com/" title="Optional Title Here">an example</a>
reference-style link.

in the editor preview, but to

This is <a href="http://example.com/">an example</a> reference-style link.

after editing.

EDIT: I cannot reproduce this problem on another site ([english.se]), which is why I am reporting it here and not on [meta.se].

EDIT: A post which illustrates the problem in the wild is: https://softwareengineering.stackexchange.com/a/186318/39089

EDIT: The problem was not reproducible after saving an edit to the post – even though the edit has nothing to do with the link. The problem was still not reproducible even after rolling the edit back. HOWEVER, between 2013 and 2016 the bug resurfaced. The post does exhibit the problem again, and presumably will continue to do so as long as nobody edits the post.

1

It appears you have smart quotes in there:

Original:

test (this one does not work... or shouldn't, but might)

[1]: http://etymonline.com/index.php?search=argue "b. 2013 “EtymOnline.com” search=argue"

Changing the reference to:

test (this one does work using the below style)

[1]: http://etymonline.com/index.php?search=argue "b. 2013 "EtymOnline.com" search=argue"

Note - this appears to not be reproducible when the post is open in an editor (I hope I've got this right, because both tests work for me at the moment...)

(After testing a bit more, this doesn't appear to point out the problem completely... it may be site specific. However, modifying the smart quotes in the linked question may fix it.)

  • Your example with "dumb" quotes seems to generate malformed HTML. The dumb quotes create an attribute title="b. 2013 "EtymOnline.com" search=argue" and I have to imagine the results of that are going to be highly browser dependent. – MetaEd Aug 13 '13 at 19:22
  • I tried removing the smart quotes from one of my links. Before doing this I was still able to reproduce the problem. After doing this I could not -- on any link in the post. Even a rollback failed to restore the problem behavior. I suppose that the generated HTML is cached somewhere? I can only guess that some bug was fixed earlier but that existing HTML generated by the buggy code was never refreshed. Bottom line is I no longer have a test case. :-( – MetaEd Aug 13 '13 at 19:27
  • Its possible its cached. I'd really consider asking this to be migrated to MSO. While some of the SE employees occasionally glance over this way into M.P.SE, there's a bug somewhere deeper and likely belongs there for more dev eyeballs on the problem - as part of the general SE network problem (I doubt its only reproducible on one site - its likely the triggers for it are a bit more complex). – user40980 Aug 14 '13 at 1:22
  • In 2013, editing the post restored the correct behavior. It did not matter that the edit was elsewhere in the post. Even after rolling back the edit, the bug did not reappear. But now the bug has resurfaced in the same post. So I will now request a migration of this report to MSO and see if it can be tracked down. – MetaEd May 3 '16 at 16:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .