1

Upon trying to insert an image as part of a post, from a web source, an error occurs saying:

format not supported

The image in question was a JPEG.

Are JPEGs no longer supported as an image format?

  • 1
    What image did you try? Could you post the URL? – Paŭlo Ebermann Nov 15 '11 at 19:31
  • @PaŭloEbermann - zoetrope.speakermouth.com/assets/2008/4/9/textmate_lisp2.jpg – Rook Nov 15 '11 at 21:11
  • @ldigas This isn't a bug: it's an issue with the image host. Your question was revised to reflect that: please do not roll it back again. – user8 Nov 15 '11 at 21:23
  • @MarkTrapp - What part of my question, now revised, differs from what I said in my original revision? – Rook Nov 15 '11 at 21:48
  • @ldigas This is a support issue, not a bug: marking things bugs when they aren't adds noise for SE developers. Additionally, .jpg isn't a file format, it's an extension. – user8 Nov 15 '11 at 21:51
  • @MarkTrapp - From my side, as a user, it's a bug. Also, I didn't say anywhere .jpg is a file format (my words were ".jpg ... image format" which is correct, if somewhat unprecise). – Rook Nov 15 '11 at 21:55
  • @ldigas I appreciate the fact that it looks like a bug to you; one of the perks of Stack Exchange is that it's collaboratively edited to ensure sure questions and answers are as accurate as possible: your question was edited to reflect that it's not actually a bug, despite its appearance. – user8 Nov 15 '11 at 21:59
  • @MarkTrapp - Oh, I don't mind that part of the edit. Edit all you want, it's your site & definition. – Rook Nov 15 '11 at 22:04
3

While this error was indicative of a problem on Imgur's end a few weeks ago, I can't reproduce this now. This is a JPEG upload:

This is a JPEG

Things to check:

  • You might be uploading a file that has the JPEG file extension but not the image/jpeg mimetype. Have you tried checking to make sure the file is actually a JPEG and not something else? If you're on a *nix-based system, you can check by using file.

  • You're using the "From the web" option with a URL from a site that doesn't allow Imgur to rip its images. Try downloading the image yourself and uploading it manually.

  • You're experiencing a localized disruption of Imgur. Try uploading the image again to see if it works.


Edit

While the "From the web" option didn't work, downloading it first and manually uploading it worked:

Image problem

Looks like it's a problem with the image host.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .